re = /^\d+\.\h+\K[^\n+-]*[^\s+-](?=\h*[+-])/m
str = '1. Medium Size +CA $33.00
2. Small Size -CA $4.00
3. Small Size-CA $4.00
4. Small Size CA $4.00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end