#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\B([\"'`]).+?\1\B"
Local $sString = ""Come up and see me some time" # correct" & @CRLF & _
"'Yeah, I wonder if will pick this up to' #correct" & @CRLF & _
"'Yeah, I wonder if will pick this up to" # Wrong." & @CRLF & _
"`Mmmm. I wonder...` # correct" & @CRLF & _
""Sorry about the mess!" #correct" & @CRLF & _
"We don't know who is human. Don't we? # Wrong. " & @CRLF & _
"'We don't know who is human. Don't we? # Wrong. " & @CRLF & _
"'We don't know who is human. Don't we?' # correct "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")