const regex = new RegExp('\\B([\\"\\'`]).+?\\1\\B', 'g')
const str = `"Come up and see me some time" # correct
'Yeah, I wonder if will pick this up to' #correct
'Yeah, I wonder if will pick this up to" # Wrong.
\`Mmmm. I wonder...\` # correct
"Sorry about the mess!" #correct
We don't know who is human. Don't we? # Wrong.
'We don't know who is human. Don't we? # Wrong.
'We don't know who is human. Don't we?' # correct `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}