using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:(?:(?:f|ht)tps?:\/\/)|(?:www\.))[-\w+&@#\/%?=~|!:,.;]*[-\w+&@#\/%=~|]";
string input = @"https://www.example.com
http://www.example.com
ftps://www.example.com
ftp://www.example.com
https://example.com
http://example.com
ftps://example.com
ftp://example.com
www.example.com
https://www.example.com?u=123&txt=abc#anchor
http://www.example.com#:~:text=hightlightfromhere,tohere
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}