import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:(?:(?:f|ht)tps?:\\/\\/)|(?:www\\.))[-\\w+&@#\\/%?=~|!:,.;]*[-\\w+&@#\\/%=~|]";
final String string = "https://www.example.com\n"
+ "http://www.example.com\n"
+ "ftps://www.example.com\n"
+ "ftp://www.example.com\n"
+ "https://example.com\n"
+ "http://example.com\n"
+ "ftps://example.com\n"
+ "ftp://example.com\n"
+ "www.example.com\n"
+ "https://www.example.com?u=123&txt=abc#anchor\n"
+ "http://www.example.com#:~:text=hightlightfromhere,tohere\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}