const regex = /\b(?:(?:(?:f|ht)tps?:\/\/)|(?:www\.))[-\w+&@#\/%?=~|!:,.;]*[-\w+&@#\/%=~|]/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:(?:(?:f|ht)tps?:\\\/\\\/)|(?:www\\.))[-\\w+&@#\\\/%?=~|!:,.;]*[-\\w+&@#\\\/%=~|]', 'ig')
const str = `https://www.example.com
http://www.example.com
ftps://www.example.com
ftp://www.example.com
https://example.com
http://example.com
ftps://example.com
ftp://example.com
www.example.com
https://www.example.com?u=123&txt=abc#anchor
http://www.example.com#:~:text=hightlightfromhere,tohere
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}