# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(?:(?:(?:f|ht)tps?:\/\/)|(?:www\.))[-\w+&@#\/%?=~|!:,.;]*[-\w+&@#\/%=~|]"
test_str = ("https://www.example.com\n"
"http://www.example.com\n"
"ftps://www.example.com\n"
"ftp://www.example.com\n"
"https://example.com\n"
"http://example.com\n"
"ftps://example.com\n"
"ftp://example.com\n"
"www.example.com\n"
"https://www.example.com?u=123&txt=abc#anchor\n"
"http://www.example.com#:~:text=hightlightfromhere,tohere\n\n")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.