import Foundation
let pattern = ##"\b(?:(?:(?:f|ht)tps?:\/\/)|(?:www\.))[-\w+&@#\/%?=~|!:,.;]*[-\w+&@#\/%=~|]"##
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = ##"""
https://www.example.com
http://www.example.com
ftps://www.example.com
ftp://www.example.com
https://example.com
http://example.com
ftps://example.com
ftp://example.com
www.example.com
https://www.example.com?u=123&txt=abc#anchor
http://www.example.com#:~:text=hightlightfromhere,tohere
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)