Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
(?P<url>https?://(?:(?:www|forums)\.aeva\.asn\.au/forums|forums\.aeva\.asn\.au)[^\s\"<]+)
"
mg
Input 1
1
New
Examples of URL patterns (cross linking the AEVA forum) that need conversion ============================================================================ Thread ID: 756 http://www.aeva.asn.au/forums/forum_posts.asp?TID=132&KW= Thread ID: 1667 http://www.aeva.asn.au/forums/forum_posts.asp?TID=270 Thread ID: 1959 http://www.aeva.asn.au/forums/forum_posts.asp?TID=316&PID=1958#1958 Thread ID: 1427 http://www.aeva.asn.au/forums/forum_posts.asp?TID=65&KW=&PID=646#646 Thread ID: 1997 http://www.aeva.asn.au/forums/forum_posts.asp?TID=161&PN=1 Thread ID: Thread ID: Thread ID: Thread ID: Thread ID: Thread ID: Probably ignore these patterns, not many of them... =================================================== Thread ID: 8573 <img src="http://www.aeva.asn.au/forums/smileys/smiley4.gif" border="0" /> Thread ID: 4845 http://www.aeva.asn.au/forums/smileys/smiley18.gif Hi Andrew, <br />I cant for the life of me see how to PM. Is it enabled? <br /> <br />Anyway, here are the conversations I started that could be re-clasified if you get a chance. <br /> <br />Cheers, <br />Mal. <br /> <br />Media <br /> <br />http://www.aeva.asn.au/forums/forum_posts.asp?TID=143&KW= <br /> <br /> <br />Parts and Suppliers <br /> <br />http://www.aeva.asn.au/forums/forum_posts.asp?TID=132&KW= <br />http://www.aeva.asn.au/forums/forum_posts.asp?TID=128&KW= <br />http://www.aeva.asn.au/forums/forum_posts.asp?TID=113&KW= <br />http://www.aeva.asn.au/forums/forum_posts.asp?TID=116&KW=