using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=)([.0-9]+)";
string input = @"Refined Sunflowerseed Oil 136,000 2.26 133,000 -9.33 150,000 45.20 93,667";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}