const regex = /(?<=)([.0-9]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=)([.0-9]+)', 'gm')
const str = `Refined Sunflowerseed Oil 136,000 2.26 133,000 -9.33 150,000 45.20 93,667`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}