$re = '~(?:[^,]+,){3}~m';
$str = '000000, Регион, Населенный пункт, Название улицы, и тд.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);