using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<id>\w+)(?:\|(?:type=(?<type>\w+)|order=(?<order>\w+)|num=(?<num>\d+)|status=(?<status>\w+)|\w+=\w*))*\|?$";
string input = @"1|order=asc|type=1
1
1|order=asc|type=1
1|type=1|order=asc
1|type=1|type=2|order=asc
1|num=34|type=1|type=2|order=asc|num=14|status=done
1|num=34|type=1|type=2|order=asc|num=14|status=done|unknown=value
1|num=34|type=1|type=2|order=asc|num=14|status=done|";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}