// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<id>\w+)(?:\|(?:type=(?<type>\w+)|order=(?<order>\w+)|num=(?<num>\d+)|status=(?<status>\w+)|\w+=\w*))*\|?$").unwrap();
let string = "1|order=asc|type=1
1
1|order=asc|type=1
1|type=1|order=asc
1|type=1|type=2|order=asc
1|num=34|type=1|type=2|order=asc|num=14|status=done
1|num=34|type=1|type=2|order=asc|num=14|status=done|unknown=value
1|num=34|type=1|type=2|order=asc|num=14|status=done|";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}