using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+?)(sin|in|pak|red)$";
string substitution = @"$1tak";
string input = @"setesin";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}