const regex = /(\w+?)(sin|in|pak|red)$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+?)(sin|in|pak|red)$', 'g')
const str = `setesin`;
const subst = `$1tak`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);