use strict;
my $str = 'setesin';
my $regex = qr/(\w+?)(sin|in|pak|red)$/p;
my $subst = '$1tak';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";