import Foundation
let pattern = #"(\w+?)(sin|in|pak|red)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"setesin"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1tak"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)