import Foundation
let pattern = #"(>[^<]*)(search string)([^>]*<)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<td>test regexp find search string in text and tags<\td>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1transform string$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)