# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=<br>)\s*\R//g;t' <<< "<br>
No atraviesa el papel
<br>
No atraviesa el papel
<br>
No atraviesa el papel"