use strict;
my $str = '<br>
No atraviesa el papel
<br>
No atraviesa el papel
<br>
No atraviesa el papel';
my $regex = qr/(?<=<br>)\s*\R/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";