$re = '/(?:\||^)(\w+)=/m';
$str = 'TType=SEND|Status=OK|URL=min://j?_a=3&ver=1.1|day=3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);