$re = '/(\b\w{4,}\b)(?=(.*?\1){4,})/m';
$str = 'hello, bonjour bonjour, ceci est un test dans lequel bonjour est écrit cinq fois et test seulement quatre fois, bonjour test, bonjour test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);