re = /(\b\w{4,}\b)(?=(.*?\1){4,})/m
str = 'hello, bonjour bonjour, ceci est un test dans lequel bonjour est écrit cinq fois et test seulement quatre fois, bonjour test, bonjour test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end