package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?P<descr>\S+(?:\s\S+)*)`)
var str = `HOSE 1/4 X BSP F 3/8 Each`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}