# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=id=")([^"\n]+)"[^#\n]+#\K/\1/gm;t' <<< "<li><a id=\"a4.9\" href=\"trigger_marker.html#\">Trigger marker</a> </li>
<li><a id=\"a4.10\" href=\"timedelayarrow.html#\">Time-delay arrow</a> </li>
<li><a id=\"a4.11\" href=\"spectrumview.html#\">Spectrum view</a> </li>"