import re
regex = re.compile(r"(?<=id=\")([^\"\n]+)\"[^#\n]+#\K", flags=re.MULTILINE)
test_str = ("<li><a id=\"a4.9\" href=\"trigger_marker.html#\">Trigger marker</a> </li>\n"
"<li><a id=\"a4.10\" href=\"timedelayarrow.html#\">Time-delay arrow</a> </li>\n"
"<li><a id=\"a4.11\" href=\"spectrumview.html#\">Spectrum view</a> </li>")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)