using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(solsw-[a-z0-9]{4,}-\d+)";
string input = @"solrs013,121,192.168.1.0/26,r_Labelsolsw-b96m-02,solsw-b96m-01,DEFsolsw-b96l-001";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}