# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d{4}[a-zA-Z]{1}|\d{2}[.]\d{2}[a-zA-Z]{1})"
test_str = ("Si vous êtes coiffeur, votre code APE est alors le 96.02A (le même que pour coiffeur-barbier).\n\n"
"Si vous êtes chauffeur de VTC, votre code APE est le 49.32Z (le même que pour les taxis).\n\n"
"Si vous êtes plombier, votre code APE est le 43.22A.\n\n"
"Si vous êtes électricien, votre code APE est le 43.21A.")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.