package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)Nombre: (?<Nombre>.+)`)
var str = `De: Ultimo Test test@test.com
Información:
Nombre: Ultimo Test
Email: test@test.com
Empresa: Ataway
Teléfono: 978505752
Puesto: Manager`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}