import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{2}\\-\\w{3}\\-\\d{4}\\s\\d{2}\\:\\d{2}\\:\\d{2}\\.\\d{2}\\s(?P<src_channel>\\w+)\\s+(?P<dst_channel>\\w*)\\s(?P<code>\\w+)\\s(?P<bytes>\\d+)\\s(?P<from>\\w.+)\\srfc822";
final String string = "02-Feb-2017 09:00:01.59 tcp_imap_int Q 12 xxx@xyz.com rfc822;user@imap-internal.xyz.com user@imap.xyz.com <6940401380880269855036@PT-D69> pmdf user@imap.xyz.com: smtp;452 4.2.2 Over quota";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}