const regex = /^(?!.*test)([^+]*)\+.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*test)([^+]*)\\+.*', 'gm')
const str = `Col+djek
Col_test+deg
Col_+dege
Col_+test`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);