$re = '/^(?!.*test)([^+]*)\+.*/m';
$str = 'Col+djek
Col_test+deg
Col_+dege
Col_+test';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;