use strict;
my $str = '"double-quoted string"
\'single-quoted string\'
"unexpected EOL
\'unexpected EOL
"unclosed backslash escape: \\"
"properly doubled backslash: \\\\"
"escaped \' quotes and backslash escapes \\\' are \\" \\n allowed"
"\\t\\tindented code\\r\\n"
"invalid escape \\%"
"\'"
"space is not a valid backslash escape: \\ "
"or newline either: \\
"hopefully there aren\'t any edge-cases I didn\'t think of"
"""oh, and single-line docstrings count as three string literals, so you would have to repeat the same expression multiple times to match it"""
"""and multi-line docstrings won\'t match even if you repeat the expression multiple times';
my $regex = qr/^(?P<str_lit>(?P<begin_quote>(?P<single_quote>')|\")(?:(?(single_quote)\"|')|\\[\"']|\\[^\r\n ]|[^\"'\\\r\n])*?(?P=begin_quote))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}