import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\((?:(?!\\[\\().)*?\\)\\]";
final String string = "begin [(Mary [(had [(a )]lil' [(lamb [(whose [(fleece )])])])])]was [(white [( as )])]snow\n"
+ " 1 2 3 3 3 4 5 5 4 3 2 1 1 2 2 1\n"
+ "begin [(Mary [(had lil' [(lamb [(whose )])])])]was [(white )]snow\n"
+ " 1 2 3 4 4 3 2 1 1 1\n"
+ "begin [(Mary [(had lil' [(lamb )])])]was snow\n"
+ " 1 2 3 3 2 1\n"
+ "begin [(Mary [(had lil' )])]was snow\n"
+ " 1 2 2 1\n"
+ "begin [(Mary )]was snow\n"
+ " 1 1\n"
+ "begin was snow\n"
+ "begin was snow\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}