import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:https?:\\/\\/)?(?:(?:www|gaming)\\.)?youtube\\.com\\/(?:channel\\/|(?:c\\/)|(?:user\\/)?)([a-z\\-_0-9]+)\\/?(?:[\\?#]?.*)";
final String string = "https://www.youtube.com/c/LeSanctuaireNotreDamedeLourdes/zef\n"
+ "https://www.youtube.com/channel/UC7zlbnNCnuAPiC3goKcFgUg/zefzf\n"
+ "https://www.youtube.com/user/IciJapon/zefzef\n"
+ "https://www.youtube.com/IciJapon\n"
+ "https://www.youtube.com/c/LudovicBvideos\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}