^start of line
\s*any whitespace character, repeated any number of times
function the literal text function (case sensitive) \s+any whitespace character, repeated at least once
(?&funcname)calls group funcname as a subroutine
\s*any whitespace character, repeated any number of times
(?&args)calls group args as a subroutine
\s*any whitespace character, repeated any number of times
\{the literal { (12310 / 1738 / 7B16)