use strict;
my $str = 'function Main ($x, [string]$y) {
function Get-Content {
function main_- () {
function main([string.Array] $mfd_) { ';
my $regex = qr/(?(DEFINE)
(?<varchar> [[:alnum:]] | [-_] )
(?<funcname> [[:alpha:]](?&varchar)* )
(?<varname> \$(?&funcname) )
(?<typepart> [[:alpha:][[:alnum:]]*)
(?<typename> \[ (?&typepart) ( \.(?&typepart) )* \] )
(?<arg> (?&typename)? \s* (?&varname) )
(?<arglist> (?&arg) ( \s*,\s* (?&arg) )* )
(?<args> ( \( (?&arglist)? \) )? )
(?<func_decl> ^ \s* function \s+ (?&funcname) \s* (?&args) \s* \{ )
)
(?&func_decl)/xmp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";