re = /(?:http(?:s|):\/\/(?:www\.|)example\.com\/)([^\/]+)\/(season-[0-9]{1,}|)((.+)\.html)/m
str = 'https://example.com/serial/season-2/episode-3.html
https://example.com/serial/episode-1.html
http://example.com/serial/season-21/episode-3.html
http://example.com/serial/episode-1.html
https://www.example.com/serial/season-233/episode-3.html
https://www.example.com/serial/episode-21.html
как-то так
Так же в регулярку добавил варианты протоколов и с www
Ну и вам будет нужно то
$1 -название сериала
$2 эпизод если он есть
$3 эпизод без хтмл
$4 Эпизод с .html
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end