#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\.?(?!-)\d+(?:\.\d{1,2})?$"
Local $sString = "123.12" & @CRLF & _
"2" & @CRLF & _
"56754" & @CRLF & _
"92929292929292.12" & @CRLF & _
"0.21" & @CRLF & _
"3.1" & @CRLF & _
".90" & @CRLF & _
"" & @CRLF & _
"12.12dd" & @CRLF & _
"2.23332" & @CRLF & _
"e666.76" & @CRLF & _
"-1.23" & @CRLF & _
"-54.3242" & @CRLF & _
"3.98A" & @CRLF & _
"56B" & @CRLF & _
"BBB.12C" & @CRLF & _
"14.23.56" & @CRLF & _
"1..45"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")