#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)<!--(.*?)-->|<(?P<tag>[a-z0-9]+?)[^>]*>.*?<\/(?P=tag)>|<([a-z0-9]+).*?\/>|[\S ]+"
Local $sString = "<!--comment1" & @CRLF & _
" -->" & @CRLF & _
"<h1>header</h1>" & @CRLF & _
"" & @CRLF & _
"<img src="http://example.com/img.png" title="single tag"/>" & @CRLF & _
"" & @CRLF & _
"<p>long text</p>" & @CRLF & _
"" & @CRLF & _
"<img src="http://example.com/img2.png"" & @CRLF & _
" title="single tag"/>" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"<!-- comment1 -->" & @CRLF & _
"<ul>" & @CRLF & _
" <li>item1</li>" & @CRLF & _
" <li>item2</li>" & @CRLF & _
" <li>item3</li>" & @CRLF & _
"</ul>" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"some text" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<br class="unclosed">" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")