use strict;
my $str = 'the number of CNC machines equalled 5
Here some additional samples of what I want to match "CNC operators numbering 12" and the reverse like "There are 12 qualified CNC operators on site"
Basically any number within a 6 word count of the key phrase. –';
my $regex = qr/(\d+)\W+(?:\w+\W+){0,5}CNC\b|\bCNC\W+(?:\w+\W+){0,5}(\d+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}