import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "frame_\\d+_time_\\d+(_\\d\\d){5}\\.\\d+_exp_-?\\d+_ag_-?\\d+\\.\\d+_dg_-?\\d+\\.?\\d+_exp_st_\\d+_wb_st_\\d+_foc_\\d+_o[lr]t_dgRGGB_\\d+.\\d+.\\d+.\\d+_rFix_-?\\d+_bFix_-?\\d+[.](pgm|jpg)";
final String string = "frame_00091_time_2017_09_19_15_42_43.649_exp_40000_ag_6.5_dg_-1.0_exp_st_0_wb_st_1_foc_1_ort_dgRGGB_139.100.100.181_rFix_0_bFix_0.pgm";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}