package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\p{Ll}`)
var str = `customer.presentAddress.streetName`
var substitution = "\U\0"
fmt.Println(re.ReplaceAllString(str, substitution))
}