import re
regex = re.compile(r"[^.,:;!?_@%*\"\-\'\(\)\[\]s\0-9a-zA-Z\x{4e00}-\x{9fa5}()?,、;。:“”!]+", flags=re.UNICODE | re.IGNORECASE | re.DOTALL)
test_str = ("清楚中文以外的文字:日文にっぽんご/にほんご 韩文:조선글/朝鮮글 德语:Användarnamn Världens 100 största språk 2010 [阿拉伯语:أَبْجَدِيَّة عَرَبِيَّة,abjadīyah ʻarabīyah)\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")