#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?![ \t]*[sg]et[ \t]+\{.*\}).*\S[ \t]*\{"
Local $sString = "override var cornerRadius: CGFloat" & @CRLF & _
"{" & @CRLF & _
" get { return layer.cornerRadius }" & @CRLF & _
" set { layer.cornerRadius = newValue }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"function Name(...) {" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")