$re = '/^(?!\h*[sg]et\h+\{.*\}).*\S\h*\{/m';
$str = 'override var cornerRadius: CGFloat
{
get { return layer.cornerRadius }
set { layer.cornerRadius = newValue }
}
function Name(...) {
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);