#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(.*)\/jobs\/\?(.*)"
Local $sString = "https://www.test.com/jobs/?test"
Local $sSubst = "$1\/job\/$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)