$re = '/(?<=KEYWORD |^(?!.*KEYWORD)).*/m';
$str = 'abc KEYWORD this is a random sentence
this is another random sentence';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);