import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^.+[^/f/])";
final String string = "/televizory-i-cifrovoe-tv/televizory-65?reff=menu_main\n"
+ "/televizory-i-cifrovoe-tv/televizory-65/f/category=4k-uhd-televizory-1682?reff=menu_main\n"
+ "/televizory-i-cifrovoe-tv/televizory-65/f/category=led-8k-televizory-6947?reff=menu_main\n"
+ "/televizory-i-cifrovoe-tv-1/televizory-65/f/smart-tv=da?reff=menu_main\n"
+ "/televizory-i-cifrovoe-tv/televizory-65/f/kvantovij_tochki_tv=da?reff=menu_main\n"
+ "/televizory-i-cifrovoe-tv/televizory-65/f/category=oled-televizory-1987?reff=menu_main\n"
+ "/televizory-i-cifrovoe-tv-1/televizory-65/f/collection_bottom=seriya-frame?reff=menu_main";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}